Author Topic: Installation help needed  (Read 4293 times)

glucas

  • Guest
Installation help needed
« on: October 03, 2011, 07:27:28 PM »
My thanks in advance to anyone willing to help me set this up.

I have tested PHP install and mod_rewrite, both are enabled on my server with PHP v5.2.6 I have imported all the tables and the DB is viewable via myPHPAdmin.

First question regards the config.php file. In the example from the read me file, the code is:

define( 'DB_SERVER', 'localhost' );
define( 'DB_USER', '' );
define( 'DB_PASS', '' );
define( 'DB_NAME', '' );
define( 'DB_PREFIX', 'jobberland_' );
define( 'JOB_INSTALLED', '0' );

I assume, I would enter the values of mySQL installation here. For example, the MySQL DB name is 'jobberland_' and the admin user and password are 'jb_admin' and 'password' (for now).

So, I would then enter those credentials into the script above:


define( 'DB_SERVER', 'localhost' );
define( 'DB_USER', 'jb_admin' );
define( 'DB_PASS', 'password' );
define( 'DB_NAME', 'jobberland_' );
define( 'DB_PREFIX', 'jobberland_' );
define( 'JOB_INSTALLED', '0' );

However, when I do so, I get the following error:
BLANK PAGE (no errors)
When I view source on the resulting page, I get no source either so PHP is not executing anything.

If I change credentials above to admin (as suggested at the end of the read me file, thus:
define( 'DB_SERVER', 'localhost' );
define( 'DB_USER', 'admin' );
define( 'DB_PASS', 'admin' );
define( 'DB_NAME', 'jobberland_' );
define( 'DB_PREFIX', 'jobberland_' );
define( 'JOB_INSTALLED', '0' );

I get the following error:
Database connection failed.Access denied for user 'admin'@'localhost' (using password: YES)

Can someone please clarify for me how the config.php file should be set up? I'm a newbie, so my apologies.






glucas

  • Guest
Re: Installation help needed
« Reply #1 on: October 04, 2011, 06:09:15 PM »
I believe I have followed the install read me to the letter and the script does not work. Can someone who has gotten an installation to work please chime in with a more detailed install read me? I would really appreciate the help!

I get the following error:
Database connection failed.Access denied for user 'tb_admin'@'localhost' (using password: YES)


glucas

  • Guest
Re: Installation help needed
« Reply #2 on: October 07, 2011, 06:34:16 PM »
I believe I have followed the install read me to the letter and the script does not work. Can someone who has gotten an installation to work please chime in with a more detailed install read me? I would really appreciate the help!

I get the following error:
Database connection failed.Access denied for user 'tb_admin'@'localhost' (using password: YES)



Anyone? I'd be willing to make a donation $$$ to the developers (if I can get this to actually work!) or to someone else that is available for hire.

Also, I am able to connect to the MySQL database remotely, so I know that it is set up correctly, but I cannot get the script to work.
« Last Edit: October 07, 2011, 06:37:14 PM by glucas »

AllMenaJobs.com

  • Guest
Re: Installation help needed
« Reply #3 on: December 27, 2011, 01:07:28 AM »
Hi :)

You need to have a data base user already set up in your phpMyadmin and you need to give that user privileges to you job board database.

Also, if your database is not on your local machine (your pc), you need to change the data base host name too.

And try not using the tables prefix (jobberland_) as your database name.

Hope this helps.

Offline memo

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Installation help needed
« Reply #4 on: January 31, 2013, 10:22:02 AM »
 :'(
please help can not install
when i go to link admin
find this error

Notice: Undefined index: HTTPS in C:\xampp\htdocs\jobs\libs\initialise.php on line 17

Notice: A session had already been started - ignoring session_start() in C:\xampp\htdocs\jobs\libs\class.session.php on line 17

Notice: Use of undefined constant TEMPLATE - assumed 'TEMPLATE' in C:\xampp\htdocs\jobs\libs\initialise.php on line 70

Notice: Use of undefined constant JOBLASTFOR - assumed 'JOBLASTFOR' in C:\xampp\htdocs\jobs\libs\class.job.php on line 66

Notice: Use of undefined constant SITE_IN_DEVELOPER_MODE - assumed 'SITE_IN_DEVELOPER_MODE' in C:\xampp\htdocs\jobs\libs\class.database.php on line 116
Database query failed Table 'mena.jobberland_job' doesn't exist
Last Query run : SELECT * FROM jobberland_job WHERE has_been_active='Y' AND job_status ='approved' AND DATE_ADD( created_at, INTERVAL JOBLASTFOR DAY ) < NOW()

Offline lalajee

  • Administrator
  • Newbie
  • *****
  • Posts: 17
  • Karma: +1/-0
    • View Profile
Re: Installation help needed
« Reply #5 on: January 31, 2013, 12:16:14 PM »
Have you upload all of the files, it looks like you missing the tables. Please make sure you have upload all of the sql files to your database.

Logon to your hosting and then go into your phpmyadmin to see if the tables existed.

OPJobBoard

Re: Installation help needed
« Reply #5 on: January 31, 2013, 12:16:14 PM »